Grandstream Networks, Inc.

UCM6xxx Series
User Portal Guide
# Table of Contents

**INTRODUCTION** .................................................................................................................................................. 4

**LOGIN TO THE USER PORTAL** ....................................................................................................................... 5

**BASIC INFORMATION** .................................................................................................................................. 6

  User Information .................................................................................................................................................. 6
  Personal Config ................................................................................................................................................... 7
  Extensions ......................................................................................................................................................... 7
  CDR (Call Detail Records) ................................................................................................................................. 10
  Change Information ........................................................................................................................................... 10

**PERSONAL DATA** ............................................................................................................................................. 11

  Follow Me .......................................................................................................................................................... 11
  Voicemail ......................................................................................................................................................... 12
  Recording Files ............................................................................................................................................... 13
  Fax Files ......................................................................................................................................................... 13

**VALUE-ADDED FEATURES** ............................................................................................................................ 14

  Fax Sending ....................................................................................................................................................... 14
  Call Queue ...................................................................................................................................................... 14
  Wakeup Service ............................................................................................................................................... 15
  CRM User Settings ....................................................................................................................................... 16
Table of figures

Figure 1: User Portal Login ................................................................. 5
Figure 2: User Portal Layout ............................................................. 5
Figure 3: Basic Information → User Information .................................. 6
Figure 4: Basic Information → Personal Config .................................... 7
Figure 5: Basic Information → Extensions → Basic Settings ................ 8
Figure 6: Basic Information → Extensions → Features .......................... 9
Figure 7: Basic Information → Extensions → Specific Time ................. 9
Figure 8: Basic Information → CDR .................................................... 10
Figure 9: Basic Information → CDR .................................................... 10
Figure 10: Personal Data → Follow Me .............................................. 11
Figure 11: Personal Data → Voicemail .............................................. 12
Figure 12: Personal Data → Voicemail – Voicemail Prompt ................ 12
Figure 13: Personal Data → Recording Files ....................................... 13
Figure 14: Personal Data → Fax Files ............................................... 13
Figure 16: Value-added Features → Fax Sending ................................ 14
Figure 17: Value-added Features → Call Queue ................................. 15
Figure 18: Value-added Features → Wakeup Service .......................... 16
Figure 19: Value-added Features → CRM User Settings ........................ 17

Table of tables

Table 2: Wakeup Service Parameters .................................................. 16
INTRODUCTION

Other than the web interface access for administrators, Grandstream UCM6xxx IP-PBX series offer to each extension a “User Portal” allowing to manage extension own data and information by the user from the web UI with no need of administrator intervention. Using the User Portal will reduce administrator interventions to the system for basic extension operations which will be managed by the extension owner directly.

A user portal account is automatically available upon extension creation and is designed to give access to a variety of features covering user information, extension configuration, CDR (Call Detail Records), and value-added features such as Fax Sending, Call Queue, wakeup Service and CRM (Customer relationship management). These features are categorized into 3 main menus: Basic Information, Personal Data and Value-added Features.

This document introduces the user portal features and offers step by step instructions to use them.
LOGIN TO THE USER PORTAL

After creating an extension, the super Administrator can configure/edit the login credentials for the user portal under UCM6xxx Web GUI → Maintenance → User Management → User Information.

Users will use only their extension number and the password set by the admin to access to the user portal as shown in below figure.

The UCM6xxx User Portal Web GUI appears once you click “Login”. The following figure shows the user portal interface:
BASIC INFORMATION

Basic Information menu includes following sub-menus:

- User Information.
- Personal Config.
- Extensions.
- CDR (Call Detail Records).
- Change Information.

User Information

User Information page displays the extension call features statuses including Voicemail, DND whitelist, Call Transfer, No Answer, Follow Me, and Conference Schedule.

The user can press **Start** button to enable and configure a call feature directly.

Figure 3: Basic Information ➔ User Information
**Personal Config**

Personal Config page allows the user to edit his/her personal information including Department, Fax Number, Email Address, First Name, Last Name, Home Number and Mobile Phone Number.

The “User Name” cannot be edited from the User Portal. Only Admin can edit this field if needed.

![Personal Config Page](image)

**Extensions**

Extension page is divided into 3 tabs as follows:

1. **Basic Settings**: Allows to:
   - Change the SIP Extension Password and Authentication ID.
   - Enable/Disable Voicemail and set the Voicemail Password.
   - Enable/Disable the extension.
   - Select the extension prompts language.
2. **Features**: The extension configuration parameters in this menu provide the user with a variety of call features to perform, such as:

- **Presence**: Set up presence status of the extension (6 statuses are available).

- **Call Transfer**: Configure call forward for each presence status. (Call Forward Unconditional, Call Forward No Answer, Call Forward Busy and FWD Whitelist).

- **Do Not Disturb**: Enable/Disable DND feature and configure its conditions including DND Whitelist.

- **Ring Simultaneously**: Enable/Disable “Ring Simultaneously” feature and configure its conditions.

- **Seamless transfer privilege control**: Select the extensions that can perform seamless transfer to the user’s extension.

- **Ring Timeout**: Configure the ring time out parameter for the extension.
3. **Specific Time**: User can configure specific time for his extension to use time condition based features.
CDR (Call Detail Records)

The CDR page provides to the user all the call records details related to his extension.

![CDR Page](image)

**Figure 8: Basic Information → CDR**

**Notes:**

- User can also filter records by: start/end time, Caller Number/Name, Call Number, Action Type, Call Type, and Status. Click on **Filter** button to have the filtering menu and once the criteria are set then click on **button in order to process the request and get the desired result.

- User can also download all his CDR records in an excel file from the user portal.

**Change Information**

User can easily change the user portal password by entering the old one already set by the administrator and setting a new one. In addition to this, user Email Address can also be set or modified in this menu.

![Change Information](image)

**Figure 9: Basic Information → CDR**
PERSONAL DATA

Personal Data menu includes following sub-menus:

- Follow Me.
- Voicemail.
- Recording Files.
- Fax Files.

Follow Me

This page allows the user to configure Follow Me feature for his own extension.

Follow Me is a very useful feature to locate a user by ringing different extensions and external numbers in a pre-defined order. This feature allows users to be reached at numerous devices, such as mobile, home-telephone, office-telephone, or softphones.

![Follow Me User Preference](image)

**Figure 10: Personal Data ➔ Follow Me**
Voicemail

User can view all the voicemails he received under the UCM6xxx portal Web GUI → Personal Data → Voicemail. He can download them as well by clicking on , delete them by clicking on or Mark them as Read by clicking on the button.

![Voicemail Table]

Figure 11: Personal Data → Voicemail

User can also customize his Voicemail greetings messages by uploading a custom prompt for each greeting message. To do so, user needs to click on and upload a prompt for each status.

Notes:

- Available greetings are:
  - **Busy**: The corresponding message will be played when the extension is busy.
  - **Unavail**: The corresponding message will be played when the extension is unavailable.
  - **Temp**: Highest priority. If exists, the corresponding message will be played.
  - **Greet**: This is the welcome message played when reaching extension VM.

The priority is "temp > busy/unavail > greet".

- Sounds file must be PCM encoded, 16 bits at 8000Hz mono with mp3/wav format or raw ulaw/aler/wav file with .mp3/.wav/.ulaw/.alaw/.gsm suffix. The file size must be less than 5MB.

![Voicemail Prompt]

Figure 12: Personal Data → Voicemail – Voicemail Prompt
Recording Files

From this menu, the user can find all the Extension Call Recordings under the UCM6xxx portal Web GUI → Personal Data → Recording Files, with the possibility of playing them on the user portal interface by clicking ♫ button or download them to his personal computer.

![Recording Files](image)

**Figure 13: Personal Data → Recording Files**

Fax Files

User can view all the faxes he received under the UCM6xxx portal Web GUI → Personal Data → Fax Files. He also can download the files by clicking on ⬇️, or delete them with the button ❌.

![Fax Files](image)

**Figure 14: Personal Data → Fax Files**

**Note:** Two copies of each fax file are available, one in .pdf format and a second in .tiff format.
VALUE-ADDED FEATURES

Value-added Features menu includes following sub-menus:

- Fax Sending.
- Call Queue.
- Wakeup Service.
- CRM User Settings.

Fax Sending

This page provides ability to send PDF or TIF/TIFF fax files to external fax destination.

The steps below describe the basic configuration required to send a fax to an external fax number:

1. Go to UCM6xx User Portal GUI → Value-added Features → Fax Sending.
2. Enter the destination “External Fax Number”.
3. Click on “Choose file to upload” and Select the file you want to send.

Figure 15: Value-added Features → Fax Sending

Notes:

- Only PDF or TIF/TIFF files are accepted.
- The “File Send Progress” field shows all the information about the faxes that have been sent and gives to the user an idea about the percentage of the fax current progress.

Call Queue

As member of a call queue, the user can manage his calls from the user portal. The page also provides a user dashboard displaying waiting calls and call statistics.
The following figure shows the Switchboard seen by the user 5000 who is a queue agent and can see only his own information under the user portal.

**Figure 16: Value-added Features → Call Queue**

<table>
<thead>
<tr>
<th>Waiting</th>
<th>Proceeding</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Status</td>
</tr>
<tr>
<td>Caller</td>
<td>Caller</td>
</tr>
<tr>
<td>Callle</td>
<td>Callle</td>
</tr>
<tr>
<td>Position</td>
<td>Position</td>
</tr>
<tr>
<td>Talk Time</td>
<td>Talk Time</td>
</tr>
<tr>
<td>Options</td>
<td>Options</td>
</tr>
</tbody>
</table>

| 3000 | 6500 | 1 | 2017-08-25 06:44:34 | 3003 | 5000 | 2017-08-25 06:47:08 |

**Waiting**

This menu shows the current waiting calls along with the caller id and the option to hang-up call by pressing on the button.

**Proceeding**

Shows the current established calls along with the caller id and the callee (agent) as well as the option to hang-up or to transfer the call using the button.

**Agents**

Displays the agent extension status (idle, ringing, in use or unavailable) along with some basic call statistics and agent’s type (static or dynamic).

**Wakeup Service**

User can schedule a reminder or wake up calls to its extension using the UCM6xxx user portal.

Please refer to the following steps:

1. Login to the user portal on the UCM6.
2. WakeUp service can be found under “Value-added Features → Wakeup Service”, click on to create a new wakeup service.
3. Configures the Name, Prompt, Date and Time for the user to make the wakeup to.
4. Click and to apply the changes.
Table 1: Wakeup Service Parameters

<table>
<thead>
<tr>
<th>Enable Wakeup Service</th>
<th>Enable Wakeup service.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name to identify the wakeup service.</td>
</tr>
<tr>
<td>Prompt</td>
<td>Select the prompt to play for that extension.</td>
</tr>
<tr>
<td>Custom Date</td>
<td>If disabled, users can select a specific date and time. If enabled users can select multiple days of the week to perform the wakeup.</td>
</tr>
<tr>
<td>Date</td>
<td>Select the date or dates when to performs the wakeup call.</td>
</tr>
<tr>
<td>Time</td>
<td>Select the time when to play the wakeup call.</td>
</tr>
<tr>
<td>Members</td>
<td>Select the members involved within the wakeup group.</td>
</tr>
</tbody>
</table>

**CRM User Settings**

User can start using CRM feature once settings on admin access are configured with supported CRM platforms (currently only SugarCRM and Salesforce are supported).

Refer to the following steps to Login to CRM account:

1. Navigate under UCM6xxx portal GUI → **Added-Value Features** → **CRM User Settings**
2. Click on Enable CRM.
3. Enter the Username associated with CRM Account.
4. Enter the Password associated with CRM Account.
5. Click on “Save” and “Apply Changes”.

---

**Figure 17: Value-added Features → Wakeup Service**
Figure 18: Value-added Features → CRM User Settings

The status will change from "Logged Out" to "Logged In" and the user can start then using CRM features.